Create a Stream Control Transmission Protocol (SCTP) Protection profile to specify the ways in which you want the firewall to validate and filter SCTP chunks. You must first enable SCTP Security (Device > Setup > Management > General Settings) in order to see this profile type under Security Profiles. You can also limit the number of IP addresses per SCTP endpoint in a multi-homed environment and you can specify when the firewall logs SCTP events. After you create an SCTP Protection profile, you then need to apply the profile to a Security policy rule for a zone.Firewall models that support SCTP security have a predefined SCTP Protection profile (default-ss7) available for you to use as is or you can clone the default-ss7 profile as the foundation for a new SCTP Protection profile. Select Object > Security Profiles > SCTP Protection and select default-ss7 to see the Operation Codes that cause an alert for this predefined profile.
Select the firewall action when it receives an SCTP packet with an unknown chunk (the chunk is not defined in RFC3758, RFC4820, RFC4895, RFC4960, RFC5061, or RFC 6525):
• allow (default)—Allow the packet to pass without modification.
• alert—Allow the packet to pass without modification and generate an SCTP log (you need to allocate log storage for these logs—see Log Storage tab under Logging and Reporting Settings: Device > Setup > Management).
• block—Nullify the chunk before passing the packet and generate an SCTP log. Select the firewall action when it receives an SCTP packet with a chunk flag inconsistent with RFC4960:
• allow (default)—Allow the packet to pass without modification.
• alert—Allow the packet to pass without modification and generate an SCTP log (you need to allocate log storage for these logs—see Log Storage tab under Logging and Reporting Settings: Device > Setup > Management).
• block—Drop the packet and generate an SCTP log.
• allow (default)—Allow the packet or chunk to pass without modification.
• block—Drop the packet and generate an SCTP log (you need to allocate log storage for these logs—see Log Storage tab.
• any—causes the firewall to take the Action you specify on all SCTP data chunks containing a PPID.
•
•
•
•
•
•
•
•
•
•
•
•
• allow (default)—Allow the chunk to pass without modification.
• alert—Allow the chunk to pass without modification and generate an SCTP log (you need to allocate log storage for these logs—see Log Storage tab under Logging and Reporting Settings: Device > Setup > Management).
• block—Nullify the chunk before passing the packet and generate an SCTP log (you need to allocate log storage for these logs—see Log Storage tab under Logging and Reporting Settings: Device > Setup > Management). SCTP packets are matched to filters in the list from top to bottom. If you create more than one SCTP filter for a profile, the order of SCTP filters makes a difference. Select a filter and Move Up or Move Down to change its relative priority in the SCTP Filtering list. Specify the action the firewall takes on Diameter chunks containing the specified Diameter Application IDs, Command Code, and AVPs. If the inspected chunk includes the specified Diameter Application ID and any of the specified Diameter Command Codes and any of the specified Diameter AVPs, then:
• allow (default)—Allow the chunk to pass without modification.
• alert—Allow the chunk to pass without modification and generate an SCTP log (you need to allocate log storage for these logs—see Log Storage tab under Logging and Reporting Settings: Device > Setup > Management).
• block—Nullify the chunk before passing the packet and generate an SCTP log (you need to allocate log storage for these logs—see Log Storage tab under Logging and Reporting Settings: Device > Setup > Management).
•
•
•
•
• Specify the Diameter Command Codes for a chunk on which the firewall takes the specified action. Select any, select one of the Diameter Command Codes from the drop-down, or enter a specific value (the range is from 0 to 16,777,215). The drop-down includes only those command codes that apply to the Diameter Application ID selected. You can add multiple Diameter Command Codes in a Diameter filter. If you create more than one Diameter filter for a profile, the order of Diameter filters makes a difference. Select a filter and Move Up or Move Down to adjust its relative priority in the Diameter Filtering list. Specify the action the firewall takes on SS7 chunks containing the specified SS7 filter elements. If the chunk being inspected contains the SCCP Calling Party SSN and any of the specified SCCP Calling Party Global Title (GT) values and any of the specified Operation Codes, then:
• allow (default)—Allow the chunk to pass without modification.
• alert—Allow the chunk to pass without modification and generate an SCTP log (you need to allocate log storage for these logs—see Log Storage tab under Logging and Reporting Settings: Device > Setup > Management).
• block—Nullify the chunk before passing the packet and generate an SCTP log (you need to allocate log storage for these logs—see Log Storage tab under Logging and Reporting Settings: Device > Setup > Management). Specify the SCCP Calling Party SSN for a chunk on which the firewall takes the specified action. Select any-map or Add one of the SCCP Calling Party SSNs from the drop-down:
•
•
•
•
•
•
• Specify the SCCP Calling Party GT value for a chunk on which the firewall takes the specified action. Select Any or Add a numerical value up to 15 digits. You can also enter a group of SCCP Calling Party GT values using a prefix. For example: 876534*. You can add multiple SCCP Calling Party GT values in an SS7 filter. For the following SCCP Calling Party SSNs, select any, or an operation code from the drop-down, or enter a specific value (range is 1 to 255):
•
•
•
•
• For SCCP Calling Party SSN: CAP, enter a value (range is 1 to 255). If you create more than one SS7 filter for a profile, the order of SS7 filters makes a difference. Select a filter and Move Up or Move Down to adjust its relative priority in the SS7 Filtering list.